HOME | ドキュメント |  ブログ  |  BBS  |  瓦版  | 将棋プロジェクト |  物置小屋   

ドキュメント 象歩 Web瓦版
 BBSボード RDF
こんにちは (23)
おためし板 (321)
質問箱 (94)
テスト (7)
建築 DIY (7)
MTB (34)
(13)
節電対策 (2)
このサイトに関する話 (182)
Linux (396)
PC用ハードウェア (10)
Vine Linux 野良系 (68)
PC 工作 (31)
BBS の改良 (105)
Vine Seed (520)
Zope とプロダクト (95)
Web の利用技術 (131)
DB とファイルシステム (63)
Python と C/C++ と... (29)
Zopeプロダクト開発メモ (3)
UTF-8 化 (42)
Mail 環境 (8)
COREBlog (109)
Zope3 (51)
Windows 64bit (18)
Mac (2)
Squeak スクイーク (67)
Django ぶらり一人旅 (3)
64bits (52)
Mono 思いにふける (13)
ディスクトップ (4)
象歩将棋 (477)
将棋よもやま (207)
サイトのデザイン (31)
心配な話 (67)
うそ (22)
昔のゲストブック (20)
ボート部 (95)
鶴南六組 (2)
Web 日記 (202)
 スパム
逮捕しる (2)
スパムお溜り (1)
ごみ箱 (12)
 リンク
kiyoさんのサイト
ペンタ郎の漫漕ブログ
TIT漕艇部の練習動画 @YouTube
墨堤の雄 @FaceBook
ペンタ(五大学ミドル) @FaceBook
Facebook
Vine Seed パッケージビルド状況
Vine Linux パッケージ情報
VineLinux バグトラッキングセンタ
VineSeed 開発用 Trac
VineSeed Specs
RPMパッケージの作成方法
Linux Standard Base
Planet Vine
Vine Linux ユーザーフォーラム
Vine Users ML アーカイブ
VineSeed ML アーカイブ
twitter#VineLinux
勝手に将棋トピックス
詰将棋おもちゃ箱

Vine Seed

Vineの開発版を中心とした話をしたいと思います。 と云いながら最近は x86_64 関連しか興味が無かったりします。 当ボードは Project Vine とは一切関係ありません。


371  owa  2007/06/14 22:35 id: mJs8kxp1Zus  prob: 0.0%
xpaint-2.7.8.1 は GUI が少し変わった。
非力な私には、旧 2.5.7 を日本語化した部分が適用できなかった。
やっぱり日本語化は (国際化して) 本家に取り込んでもらうことが必要なんだと負け惜しみ。

xpaint-2.5.7 + 日本語化版はボタンやヘルプを日本語にしてある。
だけど Canvas に日本語フォントを描画できるわけでは無い。※1
本質的じゃ無い部分を日本語化しただけだと手かせ足かせになることもある。
そう考えると自らのパッケージはひどいもの。反省しないとあかんな。

追記:
※1 そんなことはなく、日本語入力にちゃんと対応してました。重ね々々すいません。
370  owa  2007/06/13 00:42 id: mJs8kxp1Zus  prob: 0.7%
Tcl/Tk 8.4.15 にするついでに tix も少しいじってみた。
Tix8.4.2 のライブラリは /usr/lib64 の下にある。
$ wish 
% package require Tix
can't find package Tix
% puts stdout "$tcl_pkgPath"
/usr/share
% puts stdout "$auto_path"
/usr/share/tcl8.4 /usr/share /usr/lib /usr/share/tk8.4
ここが /usr/lib64 になれば宵かな?...zzz 

追記:
$ env TCLLIBPATH=/usr/lib64 wish
とすれば auto_path に /usr/lib64 が設定されることから辿り、
/usr/share/tcl8.4/init.tcl にパッチを当てた。
369  owa  2007/06/10 16:55 id: mJs8kxp1Zus  prob: 0.2%
jdk-6u1-linux-amd64.bin では mozilla plugin がサポートされて無いらしい。
http://java.sun.com/javase/ja/6/webnotes/install/system-conf...
とりあえず jdk-1.6.0_01-uvl2.nosrc.rpm を作って置くことに。
ftp://owa.as.wakwak.ne.jp/pub/vine/seed/SRPMS
368  owa  2007/06/09 22:54 id: mJs8kxp1Zus  prob: 0.1%
firefox x86_64 版の flash-plugin が無い
http://gwenole.beauchesne.info/en/projects/nspluginwrapper
を使えば i386 用の plugin が使えるというが、インストールはできない。
どうも i386 版 libX11.so.6 などが必要らしい。
結局は compat32-XOrg-* を作らないといけないのか? しばし休憩。
367  owa  2007/06/08 23:08 id: mJs8kxp1Zus  prob: 0.0%
日本語入力メソッドも使える (x86_64)
# apt-get install scim-anthy anthy
# setime scim
この記事は WindowMaker 環境で日本語入力して居ます。

今や gnome はさくさく動くのだけど、僕にはやはりまどろっこしい感じがする。
普段使うのは主に firefox, sylpheed, kterm だけなので。
366  owa  2007/06/07 22:33 id: mJs8kxp1Zus  prob: 0.0%
gnome x86_64 版が使える状態になった。
# apt-get install task-gnome
で関連パッケージがずらずらと入ってきました。startx で無事に起動。
gdm で WindowMaker と gnome の切り替えも OK
いつの間にか firefox も sylpheed も使えるようになってた^^

yelp のビルドにひっかかったおかげで pkg-config の使い方を知りました。たとえば、
$ /usr/bin/pkg-config --variable=libdir firefox-xpcom
/usr/lib/firefox-2.0

/usr/lib64/pkgconfig/*.pc でまだ libdir=/usr/lib/hoge と記述されてるものがあるようです。
あと pkg-config の man が表示されない。man ファイルが壊れてるのかしら?
365  owa  2007/06/06 23:28 id: mJs8kxp1Zus  prob: 0.0%
x86_64 のビルド環境を設定する
1) gcc の alternatives
alternatives のリンクが gcc-3.x になっていたらリンクを張り直すか、あるいは
# rpm -Uvh --replacefiles --force \
    gcc-4.1.2-0vl9.x86_64.rpm \
    gcc-cpp-4.1.2-0vl9.x86_64.rpm \

2) /etc/rpm/platform
ファイル自体を削除するか、"x86_64-vine-linux" などと書き換える?
$ rpm --eval=%{_arch}
x86_64
$ rpm --eval=%{_lib}
lib64
となることを確認する

$ echo $HOSTTYPE
x86_64
これはリブートしないと変わらない (/etc/rc.d/rc.sysinit で設定される)

3) スケルトンに ~/rpm/RPMS/x86_64 が入って無い気がする
自分で作る
364  owa  2007/06/06 23:08 id: mJs8kxp1Zus  prob: 0.0%
x86_64 化の手順
1) Vine4.1 を最小構成でインストール → Seed 化 (現時点では近道と思う)
2) x86_64 の main にある rpm をあらかじめ全部 get して置く
3) glibc-*, zlib, bzip2 を無理やり入れる (compat32-* も)
#rpm -Uvh --ignorearch --replacefiles --force *.rpm
script エラーが出るけど無視

4) kernel, kernel-devel を入れる (--oldpackage が必要かも)
initrd.img が必要な場合 /sbin/mkinitrd を修正して通すこと
http://www.is.sci.yamaguchi-u.ac.jp/~kawamura/Japanese/Comp/...

5) /etc/ld.so.conf に /lib64と /usr/lib64 を加える
リブートすれば x86_64 カーネルマシンになる

6) rpm, apt が必要とするライブラリを無理やり入れる (--replacefiles --force)
compat32-*.i686 があればなるべく利用すること。main に無ければ plus も探す。
依存関係で入らない場合は、原因となるパッケージを削除する。

7) どうしても入らなかったライブラリと rpm, apt, libstdc++34 をまとめて入れる。
/usr/lib/libstdc++.so.6 に依存するエラーだけなら --nodeps を付けて入れる。危険;;
運良く、うまくいけばこの時点で apt-get が使えるはず。でも使わない。

8) 残った hoge.rpm 達も無理やり入れる (--replacefiles --force)
9) i386 と x86_64 で重複してるパッケージを削除する
$ rpm -qa --qf "%{ARCH}-%{OS} %{NAME} %{VERSION}-%{RELEASE}\n" | grep i386
などとすれば i386 の残骸が見えるので削除 (#rpm -e hoge.i386)

a) /etc/apt/sources.list を x86_64 に向け #apt-get update; apt-get upgrade してみる
たぶん "#apt-get --fix-broken install" は必要無いはず。

追記:
http://owa.as.wakwak.ne.jp/zope/labs/bbs/201/365
363  owa  2007/06/05 22:35 id: mJs8kxp1Zus  prob: 0.0%
もう滅茶苦茶。seed マシン全滅してました;;
少し前に rpm の実行で『浮動小数点例外です〜』とか出て手も足も出ない状態に。
今日一日かけて Vine 4.0 インストールから丁寧にアップ。やっと i386 と x86_64
環境が出来た。
二歩下がって一歩前進。
何も役に立てなくてすいません。ふぅ
362  owa  2007/05/12 21:22 id: mJs8kxp1Zus  prob: 0.1%
>361 なんでだろぅ。
/dev/hda1 にブートセクタを置くのがいけないみたい。
/dev/hda (MBR) に変更したところ問題が起きません。
マシン (ASUS A8S-X) 固有の問題かも。
ということで Seed 実験機はとりあえず使える状態になりました^^